[Bug 27917] New: [regression] sound does not work, wine chooses wrong pcm

wine-bugs at winehq.org wine-bugs at winehq.org
Wed Jul 27 06:20:46 CDT 2011


           Summary: [regression] sound does not work, wine chooses wrong
           Product: Wine
           Version: 1.3.25
          Platform: x86
        OS/Version: FreeBSD
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: directx-dsound
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: naylor.b.david at gmail.com
                CC: gerald at pfeifer.com, aeikum at codeweavers.com

Created an attachment (id=35717)
 --> (http://bugs.winehq.org/attachment.cgi?id=35717)

After upgrading to 1.3.25 sound stops working, Civ V and winecfg used to test.  

Of note is:
# cat /dev/sndstat
FreeBSD Audio Driver (newpcm: 64bit 2009061500/amd64)
Installed devices:
pcm0: <HDA NVidia (Unknown) PCM #0 DisplayPort> (play)
pcm1: <HDA NVidia (Unknown) PCM #0 DisplayPort> (play)
pcm2: <HDA NVidia (Unknown) PCM #0 DisplayPort> (play)
pcm3: <HDA NVidia (Unknown) PCM #0 DisplayPort> (play)
pcm4: <HDA Realtek ALC892 PCM #0 Analog> (play/rec) default
pcm5: <HDA Realtek ALC892 PCM #1 Analog> (play/rec)
pcm6: <HDA Realtek ALC892 PCM #2 Digital> (play)
pcm7: <HDA Realtek ALC892 PCM #3 Digital> (play)

The default device, pcm4, is the device that actually plays sound however wine
uses pcm0 (as reported by winecfg).

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list