[Bug 23816] BloodlineChampions doesn't start

wine-bugs at winehq.org wine-bugs at winehq.org
Wed Jun 29 14:15:20 CDT 2011


--- Comment #23 from Louis Lenders <xerox_xerox2000 at yahoo.co.uk> 2011-06-29 14:15:19 CDT ---
(In reply to comment #22)
> The game seems to install fine without any native DLLs as of wine-1.3.6,
> but of course the game won't run without some .net or mono.
> I then tried 'winetricks dotnet35', which aborts halfway, and tried running
> the app anyway; it complained that .net 3.5 wasn't installed.  I then
> tried Louis' updated recipe at http://bugs.winehq.org/show_bug.cgi?id=22551#c5
> and was able to reproduce your error message on app startup,
> System.TypeLoadException: Could not load type
> 'System.Net.Sockets.SocketAsyncEventArgs' from assembly 'System,
> Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

Apparently also due to missing .net 2.0 SP1.

 I installed it (and .net 3.0 and 3.5), and the crash is gone.

Let's make this bug about the game not starting in mono.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list