[Bug 29119] New: HeeksCAD worked on old wine 1.2.3-2pclos2011, new 1.3.32 fails

wine-bugs at winehq.org wine-bugs at winehq.org
Thu Nov 17 16:41:31 CST 2011


             Bug #: 29119
           Summary: HeeksCAD worked on old wine 1.2.3-2pclos2011, new
                    1.3.32 fails
           Product: Wine
           Version: 1.3.32
          Platform: x86
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: blocker
          Priority: P2
         Component: wineserver
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: gheskett at wdtv.com
    Classification: Unclassified


Newbee at wine things.  I just built 1.3.32, using a 32 bit pclos install on a
quad core phenom as the user, then became root to run ./tools/wineinstall,
which didn't seem to have any major problems after it uninstalled the much
older and generally working wine that pclos supplies.

So I thought I would see how the windows HeeksCAD-18.exe ran, but total
So I figured I should reinstall HeeksCAD/HeeksCNC in case things changed, but
that also fails.

The install goes ok according to the gui, but logs this to the shell:

[gene at coyote Download]$ wine './HeeksCAD 0.18.0.exe' 2>&1
fixme:msg:ChangeWindowMessageFilter c046 00000001
fixme:win:DisableProcessWindowsGhosting : stub
fixme:sfc:SfcIsFileProtected ((nil), L"C:\\Program
Files\\HeeksCAD\\unins000.exe") stub

Then after the install the gui asks to start heeks, I click ok, and hopefully
the failure log will be generated in a format that is usable. A copy paste into
vim totally screws the moose with thousands of tabs.

Ok, more repeats with attempts to redirect the error output to a file, all
resulting in a null file.  I cannot copy paste such a large file, and it would
take me about 8 hours of editing to restore some semblance of what I see on the
screen, so how do I generate this file you would like to have attached?

This is about all that I can faithfully paste from the cli:

[gene at coyote Download]$ wine: Unhandled page fault on read access to 0x50d8458d
at address 0x45c4aa (thread 0022), starting debugger...
Unhandled exception: page fault on read access to 0x50d8458d in 32-bit code

Please advise how to proceed.

Thanks folks.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list