[Bug 30527] New: League of Legends wont open through WINE, on fresh install OR on pre-install on a Windows system.

wine-bugs at winehq.org wine-bugs at winehq.org
Fri Apr 27 08:39:09 CDT 2012


             Bug #: 30527
           Summary: League of Legends wont open through WINE, on fresh
                    install OR on pre-install on a Windows system.
           Product: Wine
           Version: 1.5.2
          Platform: x86-64
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: blocker
          Priority: P2
         Component: -unknown
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: nephallum_amathor at yahoo.com
    Classification: Unclassified

Created attachment 39933
  --> http://bugs.winehq.org/attachment.cgi?id=39933
Terminal output after doing the above terminal command to open League of

>From both a fresh WINE install of LoL, aswell as a pre-installed and
pre-patched LoL install from a WinXP system(using WINE while logged into my
Linux system) on the computer, whenever i try to run lol.launcher.exe
rads_user_kernel.exe errors out. I get the following error when running the
terminal command:
" [josh at Amathor system] wine rads_user_kernel.exe run
"/media/FEB807E8B8079DF1/Riot Games/League of Legends/lol.launcher.exe""
I run the command while already in the directory /media/FEB*/Riot Games/League
of Legends/system where the rads_user_kernel.exe is located. the kernel starts
fine, it runs lol.launcher.exe just fine. Hoever, i get a few errors in the
terminal*see attachment* and thats it. same error wether im using a
pre-installed copy of LoL or a fresh install.

I'm using WINE 1.5.2 with winetricks, I have also tried Crossover to no avail.
Running on Fedora 16 (64bit*x86_64*) with a AMD Athlon II x2 4200+ and Nvidia
430GT graphics card. Have tried with 290.x and 295.40 nvidia drivers, no
diffrence, game doesnt get that far to have a problem with the drivers. Using
GNOME 3.2 desktop enviorment with openbox.

Note: On the install of LoL I did with WINE onto my linux system, I had to use
the workaround mentioned on the LoL AppDB page, it worked beautifully, but the
launcher wont start either way. Installer wouldn't even load without doing the

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list