[Bug 29850] New: Scilab does not display Chinese

wine-bugs at winehq.org wine-bugs at winehq.org
Thu Feb 9 15:44:31 CST 2012


             Bug #: 29850
           Summary: Scilab does not display Chinese
           Product: Wine
           Version: 1.4-rc2
          Platform: x86
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: -unknown
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: fracting at gmail.com
    Classification: Unclassified

1. Download Scilab installer


2. make sure "WenQuanYi Micro Hei" is installed. wqy-microhei.ttc

3. setting Chinese font replacements.
;; wine.inf
HKCU, Software\Wine\Fonts\Replacements,"SimSun",,"WenQuanYi Micro Hei"

4. wineboot

5. install Scilab with LANG=zh_CN.utf8, select Chinese language for installing.

6. start Scilab:
$ wine WScilex.exe 

Expect result:
Display Chinese
Actual result:
Chinese font is displayed as boxes, I can't find any workaround by overriding
FontLink registry. 

Extra info:
- Chinese display correctly for the Scilab installer, but wrong for WScilex.exe
- It seems WScilex.exe does not use ExtTextOutW family function for output
characters. (But the installer use ExtTextOutW)

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list