[Bug 28723] Sound stutter in Rage when emulated windows version is set to "Windows 7" (XAudio2 -> mmdevapi sound output path)

wine-bugs at winehq.org wine-bugs at winehq.org
Mon Feb 20 02:34:18 CST 2012


--- Comment #133 from Christian <christian.frank at gmx.de> 2012-02-20 02:34:18 CST ---
(In reply to comment #132)
> Alexey, Michael, Christian,
> you've been quiet lately.  I'd like to know whether my timer rate hack from
> comment #130 helps this app.  It helps against crackling sound from SC2 in bug
> #28856.
> The reason why I'm asking is that I consider the timer issue to be the last one
> that would prevent closing this bug, see comment #114.
> - A lock-free ALSA driver would be nice, but is not essential.
>   It is sketched in bug #29531.
> - The need to restart PA is undeniably a bug in PA/alsa_plugins.
>   I've submitted bug reports #46296 and #46296 to PA, see Wine bug #28856.
> - The timer rate also affects OSS in bug #29585.
> - With a correct timer and the lead-in+hidden_frames concept currently in
> place,
>   Wine should support glitch-free "worst-case" 10ms XAudio2 rendering
>   for as long as one's PC HW supports that rate. E.g. flipping screens on
>   my laptop causes interruptions so large that audio glitches.
>   I don't see how to prevent that given mmdevapi's properties, the buffers
>   and latencies are simply too small.
> >it seem that the start_threshold has no effect if you
> >are using dmix plugin, it start immmediately
> My results are opposite:  PA starts immediately (with threshold=1).  dmix
> strictly works in periods, both when starting and with trailing frames, not
> caring whether threshold equals 1 or period_size-1.

Hi Jörg,

i just tested Starcraft and Skyrim with Wine 1.4 rc4 and everything works fine.
No sound issues at all.Also Hard Reset, Wolfenstein and the new Jagged Alliance
Back in Action have perfectly working sound. For me so far you did a GREAT JOB 
fixing all those ugly sound issues ! Many thanks for that ! 

This was tested with pure alsa on 11.10 and a sb 512 pci.

I can't get rage up and running right now in Wine.Will try this in the
and see how it works.


Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list