[Bug 29571] New: Chrome with User Agent Switcher unable to load any urls with --no-sandbox --single-process

wine-bugs at winehq.org wine-bugs at winehq.org
Sun Jan 8 14:10:42 CST 2012


             Bug #: 29571
           Summary: Chrome with User Agent Switcher unable to load any
                    urls with --no-sandbox --single-process
           Product: Wine
           Version: 1.3.36
          Platform: x86
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: -unknown
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: fracting at gmail.com
    Classification: Unclassified

Created attachment 38302
  --> http://bugs.winehq.org/attachment.cgi?id=38302
Log: chrome + UAswitcher


1. Download Google Chrome Standalone installer from :

sha1sum: 3700838267c7d2f01b3a4cf6802052967166bffa

2. Install with Wine:
$ wine ChromeStandalone.exe

3. Start chrome.exe with --no-sandbox switcher
$ cd .wine/drive_c/users/fracting/Local\ Settings/Application\
$ wine chrome.exe --no-sandbox ( Workaround for Wine Bug 21232 [1] )

4. open chrome://flags, enable `Experimental Extension APIs`

5. Restart chrome.exe with --no-sandbox and --single-process switchers
( Workaround for Wine Bug 27248 )
$ wine chrome.exe --no-sandbox --single-process

6. Open http://spoofer-extension.appspot.com/spoofer.crx , install
User Agent Switcher Extension

7. open any urls, with any tab, usually fails.

How reproducible:
Nearly 90%

When this bug appear, Chrome display such message in the status bar: 
"Waiting for extension User-Agent Switcher for Chrome..."

Below message seems relate to the bug:
[116:99:3876457:ERROR:proxy_resolver_winhttp.cc(79)] WinHttpGetProxyForUrl
failed: 12166

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list