[Bug 29816] Homeworld2 1.1 has no audio

wine-bugs at winehq.org wine-bugs at winehq.org
Mon Jun 11 12:20:08 CDT 2012


--- Comment #19 from Andrew Eikum <aeikum at codeweavers.com> 2012-06-11 12:20:08 CDT ---
(In reply to comment #18)
> what the…?
> You are correct: even running the modded HW2, using the complex mod, I have
> sound, *if* I run it from inside the /Release directory. Madness!
> So, uh, any idea what's going on with that?

It's probably just the way the application is programmed. I assume it's looking
for some file in the current directory, so if you run it from the wrong
directory, it fails to find that file and as a result audio doesn't work. If
you look at the shortcut on Windows, you'll see it points to .../Bin/Release.
And so does the .desktop file that Wine creates.

I tried to run the demo on my Windows 7 install to see if I could reproduce the
change in behavior there, but it refused to run. Anyways, I'm tempted to close
as INVALID. Would you object to that?

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list