[Bug 28622] alsa under pulseaudio no longer produce sound

wine-bugs at winehq.org wine-bugs at winehq.org
Sun Mar 4 05:34:51 CST 2012


--- Comment #30 from Gilboa Davara <gilboad at gmail.com> 2012-03-04 05:34:51 CST ---
(In reply to comment #27)
> Am I wrong or is Fedora involved with every PulseAudio bug in Wine, e.g. bug
> #28856?
> Maybe it's time for a bug in their bugtracker?

In previous releases (when Fedora carried winepulse) this bug would have landed
solely in Fedora bugzilla.
However, given the fact the bug *only* gets triggered by wine (other alsa-pulse
applications such as flash-plugin do not exhibit this) and given the fact that
as far as I can see, Fedora uses more-or-less stock wine, I rather try here

> That's the point where experience with other bug reports tells to restart the
> PA server.  Why does even the first write (of 30ms, 1323=3*441 frames) result
> in a underrun (EPIPE=-32)?

I restarted PA manually on two machines, one of Intel-HDA and the other with
Audigy 2, tried VLC and got the same results.
Just to verify that PA is indeed working, I played a short springrts game (oh,
life is indeed tough :)), and played a short flash video (non-HTML5).

> I fail to see what Wine does wrong.  One last idea: In
> dlls/winealsa.drv/mmdevdrv.c:alsa_enum_devices, please comment out the for loop
> involving snd_card_next.  Then only "default" (if you added nothing via the
> registry), no "plughw:N.N" will be acccessed.  Does    that change anything?

Tried using winecfg to select another device (instead of default) - no go.

> Also, may I suggest as work-around to use winecfg to have winealsa use the
> low-level "SB Audigy 2 ZS" or "HDA Intel" for output?  This may prevent other
> apps from doing output concurrently, but might give you working sound in Wine.

... Please, please, please don't break pulse.

> If you need to post another log, I recommend our render tests:
> cd dlls/mmdevapi/tests; rm /tmp/render.log
> WINETEST_INTERACTIVE=1 WINEDEBUG=+tid,+timestamp,+alsa,+mmdevapi wine
>  mmdevapi_test.exe.so render >>/tmp/render.log 2>&1
> with winecfg or the registry set your preferred device (if not "default").


- Gilboa

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list