[Bug 29168] Star Wars: The Old Republic game client hangs at intro splash

wine-bugs at winehq.org wine-bugs at winehq.org
Sun Mar 11 19:41:56 CDT 2012


--- Comment #163 from hash <HASH.DuOrden at gmail.com> 2012-03-11 19:41:56 CDT ---
(In reply to comment #155)
> I managed to solve my issues of "black screen after login" so I thought I'd
> come back and let people know what worked for me. Hopefully this works for
> hash. Aside from recompiling with KUSER_SHARED_DATA patch I had to also drop my
> gcc version from 4.6.3 to 4.5.2 before compilation. This is actually a known
> bug in gcc. I think the relevant log line is:
> fixme:dbghelp:elf_search_auxv can't find symbol in module
> For more information see
> http://appdb.winehq.org/objectManager.php?sClass=version&iId=19444.

Thank you!
That solved it, in my system I've had gcc-4.5.3. so I've compiled 4.5.2 in
/opt/gcc/4.5.2 and then compiled wine this way:
CFLAGS="-march=native -O2 -pipe --enable-frame-pointer"
./configure --prefix=/opt/wine${WINE_BUILD_TYPE} \
--with-xinput2 --without-openal --with-opengl --with-oss --with-mpg123 \
CC=/opt/gcc-4.5.2/bin/gcc CXX=/opt/gcc-4.5.2/bin/c++ CPP=/opt/gcc-4.5.2/bin/cpp
&& \
make depend && make

Now I can login with WINE!
Finally I can dish-out VMWare!
All thanks to tonedef who found tiny piece of gold in wine-bugzilla!

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list