[Bug 25060] Microsoft .NET Framework 3.5 installer does not complete

wine-bugs at winehq.org wine-bugs at winehq.org
Tue Mar 13 17:29:03 CDT 2012


--- Comment #18 from Anastasius Focht <focht at gmx.net> 2012-03-13 17:29:03 CDT ---
Hello Austin,

the last thing in log before the hang seems to be the installation of first
assembly into GAC.

--- snip ---
0032:trace:process:create_process_impl app (null) cmdline
L"C:\\windows\\Microsoft.NET\\Framework\\v2.0.50727\\ngen.exe install
\"C:\\windows\\Microsoft.NET\\Framework\\v3.0\\Windows Communication
Foundation\\ComSvcConfig.exe\" /NoDependencies /queue:2 /nologo" 
--- snip ---

Maybe mscorsvw.exe is already busy compiling assemblies from previous .NET
recipe installation and running into a race.
The service does this on its own when the WINEPREFIX is bootstrapped (through
notepad or any other process) if not told otherwise through NGEN pause.

I see you ran the installer in silent mode.
Can you run the installer in GUI mode (no /Q) without any processes in
background, being the first process that bootstraps everything?


Another idea: trigger a full rebuild of assembly cache (GAC) manually before
the installer.
Run following command:

--- snip ---
$ WINEDEBUG=+tid,+process wine
"c:\\windows\\Microsoft.NET\\Framework\\v2.0.50727\\ngen.exe" update
--- snip ---

Beware it might take a long time (several minutes) until there is no more
activity (last process exited).
Errors reports while compiling are expected, ignore/dismiss them.

Backup this WINEPREFIX for further testing.

Now test the installer with GUI and silent mode .. also with notepad already


Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list