[Bug 30256] Ancients of Ooga: very slow rendering in mid game

wine-bugs at winehq.org wine-bugs at winehq.org
Mon Mar 26 18:10:31 CDT 2012


--- Comment #6 from Matteo Bruni <matteo.mystral at gmail.com> 2012-03-26 18:10:31 CDT ---
Created attachment 39561
  --> http://bugs.winehq.org/attachment.cgi?id=39561
Hack to replace RGBA16 with RGBA8

(In reply to comment #4)
> Reading the log I had another idea though. Could you try the patch from bug
> 27879 and see if it helps here too?

Hmm, actually 6c5e109af7184ee557aa24c676cc78f3e92e6782 wasn't in 1.3.22, so the
patch from that bug can't do any difference... Sorry about it.

I'm still thinking the slowdown may have to do with
WINED3DFMT_R16G16B16A16_UNORM render targets + blending causing an emulation
fallback in the GL driver, like bug 27879. The game uses such texture format as
an additional render target which is "disabled" (not supported) by backbuffer
ORM and may be broken before the regression patch.

The game doesn't really check for availability of the texture format and
crashes if it can't create the WINED3DFMT_R16G16B16A16_UNORM render target;
something like the attached hack is the only thing I could think of for another

I hope this hack helps, otherwise I'm pretty much at a loss...

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list