[Bug 30284] Mathematica won't install

wine-bugs at winehq.org wine-bugs at winehq.org
Thu Mar 29 15:24:09 CDT 2012


--- Comment #11 from Gary Roach <gary719_list1 at verizon.net> 2012-03-29 15:24:09 CDT ---
I hope that the following information will help. I could not get to the commits
that you wanted because bisect quit working. I will need some advise on what to
do next. I seem to be fighting multiple problems but am trying to stick to the
failure to load one. The following is my log

Installed wine per regression instructions - Version 1.5.0 installed
ran to [[/media/cdrom0/setup.ext]]
Mathematica 6 started to install
The setup screen appeared. installation proceeded to "Publishing product
information" and an
"Unhandled Exception" screen popped up with Error Number 0x80020006. Setup will
now terminate.
Which it did.** The stderr output is attached as: MathInstError1.5.0    **

I then set git bisect bad
Bisecting: 701 revisions left to test after this (roughly 10 steps)
[0048a0373b93616b934f5a0395bf3616ab961aa5] d3d10core: Keep a referene to the
wined3d device in the d3d10 device.

I than ran ./configure --verbose && make 
This installed version 1.3.0
Mathematica loaded but I was not able to start the program. 
This would seem to be a separate problem. Later.
**The stderr output is attached as: MathInstError1.3.0**
I ran git bisect good (Loader worked afterall) and got:
Bisecting: 7942 revisions left to test after this (roughly 13 steps)
[4af30811a807957bb6c1957047bfc82681dcf66f] sane.ds: Mark internal symbols with
hidden visibility.

**Next itteration.**
Loaded Version 1.3.20
Mathematica loade but would not start.
**The stderr output is attached as: MathInstError1.3.20**
Set git bisect good. Return message:
**Bisecting: 3971 revisions left to test after this (roughly 12 steps)**
**error: unable to unlink old 'dlls/wineqtdecoder/qtsplitter.c' (Permission
**[b1b63af04a01e09d5a7419af49f86e1be2b6a222] mmcndmgr: Add MMC interfaces.**

**Next Itteration.**
Loaded Version 1.3.30
When winecfg run the following program error occured:
**The program rundll32.exe has encountered a serious problem**
**and needs to close. We are sorry for the inconvenience.**
winecfg started anyway, Set ALSA and Win2K
**InstallShield error:**
**1608: Unable to create InstallDriver instance. **
**Return code - 2147221163**
Install aborted.
**The stderr output is attached as: MathInstError1.3.30**
Set git bisect bad. Return message:
**Bisecting: 1985 revisions left to test after this (roughly 11 steps)**
**error: You have local changes to 'dlls/wineqtdecoder/qtsplitter.c'; cannot
switch branches.**
A recompile generated [[CompileErrors1]] attached.
I could go no further. Bisect no longer works.

Gary R

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list