ps at leissner.se
Thu Feb 15 12:20:11 CST 2001
> Patrik Stridvall <ps at leissner.se> writes:
> > * dlls/winedos/dosvm.c,
> > dlls/winedos/module.c:
> > - Added documentation
> > - Reorganized the no-DOS support.
> I don't think adding a #ifdef around each function is a good
> idea. It's much more readable with a single #ifdef around the whole
> file IMO.
More readable to a human, perhaps.
I'm not sure that I agree, but I don't really care much either way.
Let me explain why I did it insteed.
Currently winapi_check tried to check whether API functions have the
correct inline documentation and the future some other application will
generate the .spec files from inline documentation and function prototype.
In order to be able to easily do this, it is IMHO much better if all the
compile time depend variants is groups together in some standardized
way in order for the tool to easily understand that variants exist
and under what cirumstances they exist.
But sure, we could easily add a kludge in both winapi_check and
any future tools what just ignore any multiple occurance of
an already documented function. It will be more errorprone
but since this is quite rare perhaps it will not matter so much.
Anyway, I don't really very much, so just say how want it:
1. Some way similar to mine (easily parsable structure)
2. Just kludge over this rare case (ignore multiple)
3. Some other way.
More information about the wine-devel