can't debug mfc program

Aric Stewart aric at
Tue Oct 2 14:34:27 CDT 2001

This appears to not just be mfc programs.. recently I have been unable
to use gdb on any wine program with either the 2.4.0 or 2.4.9 kernels.

same problems, i get a seg fault when loading


Guilherme Kunz wrote:
> Hi!
> I am trying compile a mfc program with winelib.
> Well, i compiled the part of mfc which i need for use the program whitout
> erros or unresolved
> functions and compiled the mfc program with the without errors or
> unresolved functions,
> but when i ran the mfc program hapned "Segmentation Fault".
> I tried use gdb and winedbg but i can't run these debuggers, with gdb
> happned
> "Segmentation Fault" with or without breakpoints in the begining of the
> source and winedbg
> write only the first line in the window and go out.
> i tried use strace and "--debugmsg +all".
> HeapAlloc
> HeapAlloc
> *killed* exit_code=0
> #./program
> #Segmentation fault (core dump)
> #gdb program core
> #Reading symbols /usr/local/lib/ ...... Segmentation fault (core
> dump)
> Thank You
> Guilherme
> guiok at
> _________________________________________________________
> Oi! Você quer um iG-mail gratuito?
> Então clique aqui:

More information about the wine-devel mailing list