MSVC4, next two buttons on installer

Dan Kegel dank at
Sun Dec 22 01:41:18 CST 2002

I tried installing msvc++4.0 again with today's cvs wine.
The 'exit' button works now, which is nice, but none of
the other buttons do anything.  (Well, they highlight
when you mouse over them, and they play a sound,
but that's it.)

I discovered that under Windows, if you copy the disc's setup.exe
to the hard drive, two of the buttons do nothing, just like in Wine.
Two more buttons, however, simply launch external programs --
"Explore the CD" launches Windows Explorer on the directory containing
setup.exe, and "Standard Template Library" launches WordPad on a particular file.

OK, those sound so simple I ought to be able to get them working.

So I copied wordpad.exe and mfc42.dll from my windows system into the
same place on my fake windows area, and now when I click on
"Standard Template Library", I get "Could not load the richEdit control DLL.
The system may be low on memory or the file RICHED20.DLL may be missing or corrupt."
OK, copied that too, now that button launches wordpad,
albeit with lots of "fixme:clipboard:..." messages.

Q1. What do I have to do to get Wine's builtin rich text DLL to work there?
I tried "wine --dll riched32=b", but that didn't help.

Q2. Any idea what I'd need to do to get a Windows Explorer going
without actually installing the real Windows Explorer?-)
Does Wine have a builtin Windows Explorer clone yet?


Dan Kegel
Linux User #78045

More information about the wine-devel mailing list