Out of process COM objects & Installshield v6

Sander van Leeuwen sandervl at xs4all.nl
Mon Feb 25 05:39:58 CST 2002

On Mon, 25 Feb 2002 08:44:03 +0100, Marcus Meissner wrote:
>> After porting the OLE changes to Odin, I tried the Java 1.4 installer.
>> It fails with error 0x80070057 (CoMarshalInterface; failed to marshal interface)
>> Trying the same installer in Wine (built from latest CVS) results in the same error
>> There's a fixme for NdrDllRegisterProxy for the same GUID that fails in 
>> CoMarshallInterface. Perhaps that's the cause.
>> Before I start debugging this, I'd like to know if it is supposed to work at all.
>If you do -debugmsg +olerelay, you see that it does several interprocess
Yes, I noticed that too. A few processes are launched.

>I am not sure when and how this NdrDllRegisterProxy appeared, but I am
>experiencing the same problem.
Neither do I. Not sure if we need to implement it at all. As you said, the dreamweaver
install used to work. And Transgaming hasn't implemented this function either.

If you know when you checked this installer the last time, then we can look for the regression.

>Oh and debugging might not really help, support for proxies registered with
>NdrDllRegisterProxy needs to get implemented. :/
Are the rpcrt4 functions documented anywhere? A quick search on MSDN
didn't give any hits. (NdrDllRegisterProxy nor DllRegisterProxy)


More information about the wine-devel mailing list