FW: [ros-kernel] wine dll's on a real system. (Mingw Win2k)

Steven Edwards Steven_Ed4153 at yahoo.com
Wed Jun 12 21:29:36 CDT 2002

If anyone is interested in the win2k test results then here they are.


"Every revolution was once a thought in one man's mind"
- Ralph Waldo Emerson 

-----Original Message-----
From: reactos-kernel-admin at lists.sourceforge.net
[mailto:reactos-kernel-admin at lists.sourceforge.net] On Behalf Of Diego
Sent: Wednesday, June 12, 2002 10:55 AM
To: reactos-kernel at lists.sourceforge.net
Subject: [ros-kernel] wine dll's on a real system.

Hello gang, 

I got the wine dll's from Steven and installed them on a win2k server I
on a ADM Athlon XP1600,  256 ram, and servral gb of disk.
I documented what I saw, and the results are not good. :-(, 
This is the first round, so I will be patient. a few notes:
  * windows dies means I see the screen getting black and I see the bios
  * please ingnore the spelling/ grammar orros in the text attached.
  * if you can, you can tell me if there is a way to see which programs
which dll, that would make my life easier. 

 - diego

bureaucracy, n:
	A method for transforming energy into solid waste.
-------------- next part --------------
tested system: windows 2000 server build 2195
pc tested: AMD Athon XP 1600, 256 ram

first copied all dll to the windows dir. and booted.
win2k dies durning the winlogon. somewhere...
 * urlmon.dll
 * oleaut32.dll
 * odbc32.dll
 * oledlg.dll
 * olepro32.dll
 * winnls.dll
windows died again.

restored: wintrust.dll, comcat.dll, crtdll.dll
result : windows died

restored:  tapi32.dll
result: windows died

restored: dciman32.dll,	dinput.dll
result: windows died

restored: imm32.dll
result: windows died

restored: mapi32.dll
result: windows died

restored: dplayx.dll, mpr.dll
result: windows died

restored: netapi.dll
result: windows showed a dialog saying that libwine*.dll was not found.

copied: libwine.dll, libwine_tsx11.dll, libwine_unicode.dll.
result: winlogon.exe reports: msgina.dll could not be loaded, a restart button
is found, so I press it...

restored: comctl32.dll
result: * the same dialog openes
        * mstask.exe, says it cannt find the procedure: PathFintExtensionW(), at shlwapi.dll
        * dns.exe, says ir cannt find the procedure: DwEnumEntryDetails(), at rasapi32.dll

restored: shlwapi.dll, rasapi32.dll
result: after gzilion years (two minutes?) windows loaded, no error reported
I logged in as administrator, explorer did not load.
I press alt-ctrl-del to bring the sequrity dialog. I choosed to run the
task manager. I choose File/New task, and a dialog saying that ordinal 135 was not found in
shdocvm.dll, pressed OK. I runned again explorer. It did not load. I run windows commander,
(the browse command worked fine). Windows commander load ok. Run from the task manager notepad,
loads OK, and wrote this :)

put wine dll:  comctl32.dll
result: winlogon.exe reports: msgina.dll could not be loaded, a restart button.

restored comctl32.dll and run  a few programs.
windows commander runs.
notepad runs
winamp runs
several programs from the systemroot run, and thease gave me errors.

systomroot\setup.exe   : procedure entry not found: CheckSumMappedFile()@imagehelp.dll
systomroot\sigverif.exe: procedure entry not found: ImageAddCertificate()@imagehelp.dll
systomroot\ntbooks.exe : the instruction at "0x64d2b8c6" referenced at "0x0000" could not be "read".. ok, cancel to debug... (the window title says hh.exe)
                         procedure entry not found: ImageAddCertificate()@imagehelp.dll
systomroot\rundll32.exe: procedure entry not found: ImageDirectoryEntryToData()@imagehelp.dll

More information about the wine-devel mailing list