Re: FW: [ros-kernel] wine dll

juergen.schmied at juergen.schmied at
Thu Jun 13 04:00:11 CDT 2002

For now and a any thinkable time this won't work without native shell32, shlwapi, shdocvw and some more shell stuff since big parts of the user interface are in there. It would be more useful to replace just one dll at one time with a wine dll.
If you like to test the shell stuff, there is a registry key somewhere to set a different shell - like winfile.


"Steven Edwards" <Steven_Ed4153 at> schrieb: 
> tested system: windows 2000 server build 2195
> pc tested: AMD Athon XP 1600, 256 ram
> first copied all dll to the windows dir. and booted.
> win2k dies durning the winlogon. somewhere...
> restored:
>  * urlmon.dll
>  * oleaut32.dll
>  * odbc32.dll
>  * oledlg.dll
>  * olepro32.dll
>  * winnls.dll
> windows died again.
> restored: wintrust.dll, comcat.dll, crtdll.dll
> result : windows died
> restored:  tapi32.dll
> result: windows died
> restored: dciman32.dll,	dinput.dll
> result: windows died
> restored: imm32.dll
> result: windows died
> restored: mapi32.dll
> result: windows died
> restored: dplayx.dll, mpr.dll
> result: windows died
> restored: netapi.dll
> result: windows showed a dialog saying that libwine*.dll was not found.
> copied: libwine.dll, libwine_tsx11.dll, libwine_unicode.dll.
> result: winlogon.exe reports: msgina.dll could not be loaded, a restart button
> is found, so I press it...
> restored: comctl32.dll
> result: * the same dialog openes
>         * mstask.exe, says it cannt find the procedure: PathFintExtensionW(), at shlwapi.dll
>         * dns.exe, says ir cannt find the procedure: DwEnumEntryDetails(), at rasapi32.dll
> restored: shlwapi.dll, rasapi32.dll
> result: after gzilion years (two minutes?) windows loaded, no error reported
> I logged in as administrator, explorer did not load.
> I press alt-ctrl-del to bring the sequrity dialog. I choosed to run the
> task manager. I choose File/New task, and a dialog saying that ordinal 135 was not found in
> shdocvm.dll, pressed OK. I runned again explorer. It did not load. I run windows commander,
> (the browse command worked fine). Windows commander load ok. Run from the task manager notepad,
> loads OK, and wrote this :)
> put wine dll:  comctl32.dll
> result: winlogon.exe reports: msgina.dll could not be loaded, a restart button.
> restored comctl32.dll and run  a few programs.
> windows commander runs.
> notepad runs
> winamp runs
> several programs from the systemroot run, and thease gave me errors.
> systomroot\setup.exe   : procedure entry not found: CheckSumMappedFile()@imagehelp.dll
> systomroot\sigverif.exe: procedure entry not found: ImageAddCertificate()@imagehelp.dll
> systomroot\ntbooks.exe : the instruction at "0x64d2b8c6" referenced at "0x0000" could not be "read".. ok, cancel to debug... (the window title says hh.exe)
>                          procedure entry not found: ImageAddCertificate()@imagehelp.dll
> systomroot\rundll32.exe: procedure entry not found: ImageDirectoryEntryToData()@imagehelp.dll

More information about the wine-devel mailing list