FD_ZERO and FD_SET problems.

Patrick J. McNerthney pat at mcnerthney.com
Sun Sep 22 15:30:12 CDT 2002


>Could you please resubmit it as unified diff (diff -u)? The diff's are
>more readable and are more robust regarding to changes in the target
>file.
>
>bye
> michael

Sorry about that, I missed the step on the WineHQ website with regards
to ensuring the .cvsrc has been properly set up.

In the meantime, I have identified a couple of other problems, so I have
included those as well.

ChangeLog for winsock.h
  Removed the $undef of WS_DEFINE_SELECT so that select is in fact
defined.
  Fixed if statement in __WS_FD_SET2 which used a = where a == is
needed, in additition the if did not have it's outer set of parenthesis.
  Removed parentheses around type to be cast in __WS_FD_SET macro.
  Removed WS macro usage from within other macros because the WS macro
is undefined when these macros are expanded.
  Added WINAPI attribe to select defintion.

ChangeLog for crtdbg.h
  Added casts to all macros to avoid compiler warnings.

Pat McNerthney
Icicle Software, Inc.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: patch.diff
Type: application/octet-stream
Size: 5336 bytes
Desc: not available
Url : http://www.winehq.org/pipermail/wine-devel/attachments/20020922/c7d50d1c/patch.obj


More information about the wine-devel mailing list