Dimitrie O. Paun dpaun at
Fri Sep 27 13:12:09 CDT 2002

On September 27, 2002 01:57 pm, you wrote:
> No, it's better to always use official functions.

True, but InitThreadInput16 is not such a function, InitThreadInput is.
So we had to invent a new name that does not exist in Windows.
And I thought the policy for new names which are wine specific was
to prefix them with wine_*. But in a way I see a point in this naming
convention, as it keeps the name close to an official function. However,
it is a departure from our naming policy, right?

Also, there is a small problem with this 16-bit stuff: it is usually
called from 32-bit code, and this code has to do a 32->16 bit conversion
on handles, coordinates, etc, which are lossy. So I think it would make 
more sense to export InitThreadInput32 (if we have to export a new name 
anyway), and have InitThreadInput16 call it. This way we will have no 
deps on 16bit code, and we can compile it out (just for kicks, winelib, 
and to check that there are no 32->16 transitions).


More information about the wine-devel mailing list