Status of winealsa patch

Alexandre Julliard julliard at
Tue Dec 9 14:05:14 CST 2003

Sylvain Petreolle <spetreolle at> writes:

> The current code works with today alsa cvs if I use the ALSA_PCM_OLD*
> defines, no problem at all.
> The goal of my patch is to make us use the new API.
> When the 1.0 state will be reached, the 0.9 API will be considered
> deprecated (like the already deprecated 0.5 series)

Well, I'm not sure that's really necessary at this point. The 0.9 code
builds just fine, and IMO we can simply wait until supporting 0.9 is
no longer required and then switch to the 1.0 version, instead of
having to maintain both with #ifdefs.

Alexandre Julliard
julliard at

More information about the wine-devel mailing list