Copy & Paste doesn't work again

Rein Klazes rklazes at
Mon Jun 30 09:39:24 CDT 2003

On Sun, 29 Jun 2003 20:30:08 +0200, you wrote:

> On Sun, 29 Jun 2003 19:59:40 +0200, you wrote:
> > On Sun, 29 Jun 2003 18:26:07 +0200, Rein Klazes <rklazes at> wrote:
> > 
> > >Occasionally it seems to work again. Just restart Agent and then you
> > >find that it is not.
> > 
> > I know that it worked. I used it quite frequently. I only update yesterday,
> > but I din't do it regulrarly teh last weeks. Before that it worked fine.
> I did notice here that copying from X to Agent (the other direction) has
> stopped working completely recently. I will try to find the commit that
> did this. 

This is the commit:

| Log message:
| 	Ulrich Czekalla <uczekalla at>
| 	- use global atoms for the format ids
| 	- add timeout when calling XCheckTypedWindowEvent
| 	- fix broken IsClipboardFormatAvailable; it tried to do a trick with
| 	EnumClipboardFormats by making incorrect assumptions
| 	- in X11DRV_IsClipboardFormatAvailable do a quick exit if no one owns
| 	the selection
| 	- add 1 second *minimum* time lapse between XSelectionOwner calls
| 	- sync clipboard ownership between different wine processes
| 	- prevents apps from getting into wierd state where they thought they
| 	didn't own the selection but they did and as a result queried
| 	themselves for available selection data
| Patch:

Causing in Agent several problems:

- copy&paste from Agent to 'X' doesn't work, occasionally I see some
rubbish characters;
- copy&paste from 'X' to Agent doesn't work at all;
- copy&paste within Agent does not always work. For instance I cannot
copy Ulrich's email address from the text editor to the To:list at all.
Copying within the editor or from the cc:list to the To:list is no

Ulrich,I have never had much luck fixing things related to the
clipboard. Do you have a suggestion how to find out what the problem is?

Rein Klazes
rklazes at

More information about the wine-devel mailing list