wine-pthread hangs

Jeremy Shaw at
Fri Nov 14 21:06:14 CST 2003


I was trying to run wine-pthread, but it hangs immediately after
startup -- I can't even hit cntl-c to exit.  If I try to run it under
gdb, it seg faults. A backtrace looks like:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 14857)]
0x40040fd9 in __errno_location () from /lib/
(gdb) bt
#0  0x40040fd9 in __errno_location () from /lib/
#1  0x40515ae6 in DOSFS_ToDosFCBFormat () from /usr/lib/wine/
#2  0x40516223 in DOSFS_FindUnixName () from /usr/lib/wine/
#3  0x40516f21 in DOSFS_GetFullName () from /usr/lib/wine/
#4  0x4051e8c9 in CreateFileW () from /usr/lib/wine/
#5  0x4021c879 in RtlDoesFileExists_U () from /usr/lib/wine/
#6  0x4021cedf in RtlDosSearchPath_U () from /usr/lib/wine/
#7  0x40218862 in LdrGetProcedureAddress () from /usr/lib/wine/
#8  0x40218c1c in LdrGetProcedureAddress () from /usr/lib/wine/
#9  0x40216c80 in _aullrem () from /usr/lib/wine/
#10 0x402170d3 in _aullrem () from /usr/lib/wine/
#11 0x4021984b in LdrInitializeThunk () from /usr/lib/wine/
#12 0x405511e4 in SetThreadExecutionState () from /usr/lib/wine/

I am using the latest wine from CVS (as of 5pm, 11/14/2003).
Linux 2.4.22
libc6 2.3.2

Do I need to do something special to get this working? 

I am trying to use wine-pthread because I want to use the winejack
driver. The winejack driver does not work correctly with wine-kthread,
because in libjack, there is a call to pthread_create which never
returns. According to usenet, this could happen because wine-kthread
is not linked against libpthread explicitly. I tried adding an
explicit -lpthread to wine-kthread, but this just cause wine-kthread
to hang (similar to wine-pthread, but in a different location).

I also tried running ./configure --enable-nptl and installing a
version of libc with nptl support, but I think nptl requires features
added in 2.5.x -- so this was probably just wishful thinking.

Jeremy Shaw.

More information about the wine-devel mailing list