Delorme Street Atlas 2004 - Sooo Close...

Michael H. Warfield mhw at
Mon Aug 16 09:49:25 CDT 2004

Hey all,

	So this is my first post to the list in several years...

	I've tried several version so Delorme's Street Atlas under
many many versions of Wine over the years.  Most of the time, I haven't
even been able to get it to install.  One version, in the way WAY distant
past, did install and I had problems with the serial port and port naming
conventions that, IIRC, resulted in some patches to Wine.  But all recent
versions have been major headaches.

	I recently tried the 20040716 version of Wine and, just now, the
20040713 version.  I was able to install Street Atlas 2004 under that
previous version!  Yeah!  Some problems with things like checkboxes
in install shield not being visible (but could be checked if you guessed
right where the check box was under the image that was obscuring it)
but it did install.

	Running it becomes another matter.  If the data CD is in the
CD-Rom drive, I get the modal welcome splash window up but then I
get the following errors:

[mhw at canyon mhw]$ wine .wine/drive_c/Program\ Files/Street\ Atlas\ USA\ 2004/SA2004.exe
fixme:ole:CoCreateInstance no classfactory created for CLSID {ebbd44c6-6b55-4aa8-8a22-ceac2ede660f}, hres is 0x80040154
Fatal Error at file , line 0, char 0
err:seh:setup_exception stack overflow 236 bytes in thread 0009 eip 3545a7ab esp 17840f14 stack 0x17840000-0x17940000

	Now, the first one doesn't seem to be "fatal".  If I don't have the
CD in the CD-Rom drive, I still get that error but it come to a dialog
box asking if I want to run without the databases or if I want to browse
for them.  If I then insert the CD and hit browse and browse over to
the CD-Rom, it then hits the fatal error as before.

	The second error seems to be really bad juju.  The splash screen
just stays on top of everthing else and the whole thing seems hung.  I
can (and have to) Cntrl-C the application in the terminal window and
then the splash screen goes away as the app terminates.

	This is one Fedora Core 2 with 2.6.7 kernel.

	Any thoughts or suggestions?  Since it's a "stack overflow"
(which tend to be pretty damn serious) I figured I would raise this
issue on the developers list, rather than the users list.

	Oh...  I also used the winetools package to install things like
fonts and MS-installer and VBS runtimes, if that makes a difference.  I
was unable to install the VC++ runtime, though (didn't try that on 0813
version though).

	Any recommendations on debugging it further?

 Michael H. Warfield    |  (770) 985-6132   |  mhw at
  /\/\|=mhw=|\/\/       |  (678) 463-0932   |
  NIC whois:  MHW9      |  An optimist believes we live in the best of all
 PGP Key: 0xDF1DD471    |  possible worlds.  A pessimist is sure of it!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 307 bytes
Desc: not available
Url :

More information about the wine-devel mailing list