trouble debugging

James Hawkins truiken at
Sun Aug 29 22:41:11 CDT 2004


I'm having a real tough time debugging a program im trying to get to
run called KLConfigWizard.exe.  I had a problem earlier that was fixed
by a tip from Rob.  After trying a bunch of different native dll's
that this program uses, I located the culprit dll (which is about as
much as I seem to be able to do.)  If I use native shlwapi then the
crash doesnt happen.  When i'm not using native shlwapi, the output I
get is:

[truiken at cmu-127081 Kazaa Lite K++]$ wine KLConfigWizard.exe
Please use the registry key HKEY_CURRENT_CONFIG\Sotfware\Fonts\LogPixels
to set the screen resolution and remove the "Resolution" entry in the
config file
fixme:commctrl:InitCommonControlsEx Unknown class! dwICC=0x4000
wine: Unhandled exception (thread 0009), starting debugger...
fixme:console:SetConsoleCtrlHandler (0x405fbab0,1) - no error checking
or testing yet
WineDbg starting on pid 0x8
Unhandled exception: page fault on read access to 0x00000000 in 32-bit
code (0x00000000).
In 32 bit mode.
0x00000000: addb        %al,0x0(%eax)
=>1 0x00000000 (0x00000000)
WineDbg terminated on pid 0x8

I do have the log of WINEDEBUG=trace+all, but the log file is ~243mb? 
I tried scanning through it looking for anything that would give me a
clue, but it was hard to tell where any error was.  It also doesnt
help that the backtrace doesnt contain much of anything.  Any ideas?

James Hawkins

More information about the wine-devel mailing list