DInput has been broken for about 6 months now

Scott Ritchie scott at open-vote.org
Sat Dec 4 15:05:24 CST 2004

Well, one of my favorite games, Fallout 2, didn't work when I tried it.
This is strange though, as it was working about 3 years ago.

Looking through the AppDB page,
http://appdb.winehq.org/appview.php?appId=194&versionId=319 - it looks
like it's been broken since June.

Specifically, here's the symptoms:
"DXGRAB" = "Y" will cause the app to completely takeover and lockup the
system, except no input into the app (mouse or keyboard) works.  I have
to ctrl-alt-f2 and killall -9 wine-preloader to get back to work.

Turning off DXGRAB causes the app to respond to keyboard input, but the
mouse still doesn't work.  Some very strange things happened in gnome
when I brought my email window in front of the app (the mouse would skip
from the edge of the gnome window past the app, making it impossible to
click on, and other wierdness.  However, none of this translated into
the in-game cursor moving)  I'm running the app in Desktop=640x480 mode.

Furthermore, it appears that some of the old problems listed in the
AppsDB page are still there - the game is very slow at certain points
(well, the loading and unloading I can do with the keyboard...), and I'm
running a computer roughly 10 times as fast as was designed for the

After asking about on the channel a bit, the finger was pointed at
DINPUT.  I think some of the problems with DINPUT would make a fairly
good candidate for something to tackle on Sunday, although doing a >6
month regression test could be annoying.  I personally know about 3
people I could get to switch to Wine entirely if we could get this
working :)

I haven't filed a bugzilla report yet, but if it helps I will.


-Scott Ritchie

More information about the wine-devel mailing list