OLEPictureImpl_Load: fix for headerless pictures

Fabian Cenedese Cenedese at indel.ch
Fri Feb 6 01:28:54 CST 2004

>> Where did you disable it? My patch or yours? With my patch it should
>> never even get to try to call CreateIcon (which fails). So either the
>> field is not 0 or you don't jump out.
>I juste removed my header[1]==1, so you can say i rejected my patch.
>> >MessageBox with
>> >"Failed to load control 'SSTab' from TABCTL32.OCX. Your version of
>> >TABCTL32.OCX is outdated...."
>> This is the error I wanted to eliminate, just look for my postings with
>> SSTAB in the subject in the last two months :)
>> When I jump out if header[1] is 0 then I don't get this error anymore
>> VB programs with the SSTab control come up. But I only tried those
>> without icons as I assumed that those with icons don't have a 0 field.
>But they do have 0 field...
>I can't help you until i see how your app is supposed to work.
>Please make sure the programm runs without (header[1]==0).

That's the point, it doesn't work on wine in the current state. That's why
I try to fix wine. Use my patch (even if it's wrong for your progs) then
my app should come up and you can test what's going on.
This bug in wine prevents many VB apps from running on wine. And as
we have some of them I tried to fix it.

bye  Fabi

More information about the wine-devel mailing list