16bit app calls wineps.drv, but wine has wineps.dll (missing alias?)

ceztko at libero.it ceztko at libero.it
Mon Jan 26 16:51:11 CST 2004

I have a 16 bit app that have a older printer initialization mechanism: it loads
the printer driver reading its name from win.ini,adding ".DRV" to it. This is a
problem, cause the builtin postscript driver is called wineps.dll in wine, and
the apps quits with the VB Error (482 run-time error: Printer error).
I tryed to fix this making synlinks to wineps.dll.so in /etc/lib/wine/lib/wine,
but the problem remains.

The debug output doesn't need comments:

err:module:NE_LoadBuiltinModule loaded .so but dll wineps.drv still not found

I verifyed this using a similar configuration in a real windows installation
(renaming printerdriver.drv to .dll, leaving "printerdriver" with no ext in
win.ini). In this way, the app quits with the same error. I'm sure the app is
NOT calling registry to get the printer configuration (monitored it wit regmon)

There are other 2 old threads with similar (read indentical) problem:
but no resolution is proposed.

I supposed is missing the alias wineps.drv --> wineps.dll,
similarly wineps16.drv --> wineps.dll. Someone told me symlinks in
/usr/lib/wine/lib/wine should work....but...

This is what i have done:
-rw-r--r--    1 root     root      1815919 Jan 26 00:14 wineps.dll.so
lrwxrwxrwx    1 root     root           13 Jan 26 19:06 wineps.drv.so ->
lrwxrwxrwx    1 root     root           13 Jan 26 19:07 wineps16.dll.so ->
lrwxrwxrwx    1 root     root           13 Jan 26 00:14 wineps16.drv.so ->

The error and debugmsg are the same. I suppose (and hope..) wine loader manages
alias in a different way. 


P.S.: i also post this at bugzilla, http://bugs.winehq.org/show_bug.cgi?id=1967
Not sure it's a real bug, anyway..

More information about the wine-devel mailing list