assertion "view->next->flags & VFLAG_SYSTEM" failed: file "virtual.c", line 330

jordan lougheed mits_rox at
Tue Jun 15 19:07:29 CDT 2004

WINE BUILD: /wine-20040505

I need Internet Explorer on my workstation (openbsd 3.4) at work, so I 
decided to see if I could get the lastest wine to compile/run.

I'll list the steps required to get it to build and install.

`sh configure`
  complained about 'libGL.a' so i renamed it and the configure completed 

  ./loader/kthread.c: line 276 complained about an unknown flag `RFTHREAD` 
so i erased that flag from the code, and the build continued.  (openbsd's 
rfork doesn't support that flag, side effects are unknown)

`make install`
  wouldn't complete.
  I had to `gmake install`. worked fine.

everything is built and installed, now here is my problem.

$ wine notepad.exe
wine:/usr/local/lib/wine/ undefined symbol 'DllMain'
wine: /usr/local/lib/wine/ can't resolve reference 'DllMain'
fixme:ntdll:NtQueryVolumeInformationFile device info not properly supported 
on this platform
fixme:file:get_default_drive_device auto detection of DOS devices not 
supported on this platform
assertion "view->next->flags & VFLAG_SYSTEM" failed: file "virtual.c", line 

the "fixme:" problems seem to be common with FreeBSD, so i figure i can 
ignore them.

I always seems to hit that assertion on no matter what i run.
The first time i ran this "PokerStarsInstall.exe" it ran fine and gave me 
the install menu after configuring the "font cache". The second time it gave 
me this usual assertion.

If someone can confirm/deny that this is related the that FLAG i erased from 
kthread.c (i don't think these are related).  Or is there something else 
going on here?  If anyone can offer any help it would be appreciated.

I'm going to compile with -DNDEBUG tommorow and see what happends, until 
then i'll let you guys stew on this.

Thank you in advance,

More information about the wine-devel mailing list