Yard sale windows app fun: Lotus SmartSuite '96. 1-2-3 works, WordPro doesn't.

Mike Hearn mike at navi.cx
Sun Jun 20 06:53:46 CDT 2004

On Sat, 19 Jun 2004 16:22:01 -0700, Dan Kegel wrote:
>    err:shell:SHGetFileInfoW pidl is null!

This is either a bug in the installer (in which case we should ignore it),
or some magic feature of SHGetFileInfo. From a quick read of MSDN and
Google I can't tell which, it looks like a bug but maybe NULL has a
special meaning in this context. Would be useful to test on Windows and
find out.

> That seemed much better; Wine only printed out the SHGetFileInfoW error
> once, presumably for the lotustmp.000 directory it created in my home
> directory.

Iterating over every file on your system is a stupid habit of some Windows
installers. I think this is not a problem with Wine.
> The next problem was when a dialog box
>    "Select a Program Group..."
> popped up.  At about the same time, an error box with title "Setup
> Message" and body
> "Setup has encountered a problem.
> Please report File='COMMON\SYMTAB11.C',Line='618' to Microsoft Product
> Support Services."
> This looks a bit lot like
> http://support.microsoft.com/default.aspx?scid=kb;EN-US;113252 which
> happens when GetWindowsDirectory() returns a string with lowercase
> letters, but clicking OK let me past with no ill affects, and I was able
> to install.

OK, so it's a bug in their software, the fix seems trivial though: we can
make GetWindowsDir() return an all upper-case string easily enough.

> At least when all I installed was Word Pro. When I also tried installing
> 1-2-3 and ScreenCam, I got the error "Lotus Setup" : "Install
> encountered an error trying to start Regedit.exe." That popped up twice,
> after which install thought for a long time, then warned
> fixme:ole:CoCreateInstance no classfactory created for CLSID
> {00021401-0000-0000-c000-000000000046}, hres is 0x80040154 

This is the CLSID of the shortcut object. I guess we don't implement that,
or if we do it's not being registered properly.

> and seemed to
> get stuck.  Still, things seemed to be more or less well installed, so I
> tried running two of the apps.

> was practical to run.  Here's part of its output.  It looks as if the
> very first instruction accesses a null pointer in a strange way.

More likely the code segment of the PE file is being mapped with the wrong
permissions. When it crashes and is sitting in winedbg can you please run
cat /proc/$pid/maps where $pid is the unix process id of whatever the
wordpro wine process is.
thanks -mike

More information about the wine-devel mailing list