Has anyone done this before?

Andreas Mohr andi at rhlx01.fht-esslingen.de
Thu Nov 4 01:02:29 CST 2004


On Wed, Nov 03, 2004 at 04:00:39PM -0800, Bill Medland wrote:
> I would be interested in knowing if anyone has succeeded with this before I 
> start getting too carried away trying to fix the errors.  When I tried I got 
> an X error (BadWindow).
> I am sitting at a RedHat 8.0 computer
> with a VPN tunnel to a remote network (Microsoft VPN server)
> ssh through that VPN to a remote computer running RHEL3 (ES)
> Set DISPLAY back to my end of the VPN tunnel, to my display
> Prove it works by typing xterm in the ssh session
> Try running winemine
> After rebuilding the cached metrics it momentarily (in the non-American sense) 
> opens something and then closes it and gives me the X error.
> Does this stand a chance of actually working?
Sure, people do this all the time...
About 5 years ago I already tested a 3D virtual worlds game over an internet
connection (a VERY fast one, though ;) for short amounts of time.
It worked incredibly well (given that it was a cool 3D game working on Wine
at that time), with full 3D updates, rather fast.
You should use ssh -C, of course...

I'd say if it gives an X11 error, it's broken and should be fixed.

I have never tried winemine remotely, though.

Andreas Mohr

More information about the wine-devel mailing list