fixme:font:load_VDMX Failed to retrieve vTable

Andreas Mohr andi at
Fri Dec 9 04:51:43 CST 2005


On Fri, Dec 09, 2005 at 10:53:33AM +0100, Curro Amores wrote:
> hi my reports are not well displayed on my access97 app.
> fonts are displayed i anora location and separed
> I got this fixme
> fixme:font:load_VDMX Failed to retrieve vTable


    if(WineEngGetFontData(font, MS_VDMX_TAG, offset, group, 4) != GDI_ERROR) {
        USHORT recs;
        BYTE startsz, endsz;
        BYTE *vTable;

        recs = GET_BE_WORD(group);
        startsz = group[2];
        endsz = group[3];

        TRACE("recs=%d  startsz=%d  endsz=%d\n", recs, startsz, endsz);

        vTable = HeapAlloc(GetProcessHeap(), 0, recs * 6);
        result = WineEngGetFontData(font, MS_VDMX_TAG, offset + 4, vTable, recs
* 6);
        if(result == GDI_ERROR) {
            FIXME("Failed to retrieve vTable\n");
            goto end;

This FIXME is quite confusing and should be fixed, since it's NOT at all
about the "common" vTable term, but instead a VDMX font-related table AFAICS.

Use winedbg, set a breakpoint on load_VDMX(), step through it until the
2nd WineEngGetFontData() (that one is failing!), then step through it
until you know what exactly fails.

Maybe even a simple freetype upgrade might resolve the issue?
(in that case we'd need to know which freetype version is problematic)

Andreas Mohr

No programming skills!? Why not help translate many Linux applications!

More information about the wine-devel mailing list