OLE without TLS libraries

Cihan Altinay cihan at uq.edu.au
Sun Dec 11 18:20:22 CST 2005

Ok, I am replying to myself as the problem persists.

Quoting Cihan Altinay <cihan at uq.edu.au>:

> Quoting Marcus Meissner <marcus at jet.franken.de>:
> > On Thu, Dec 08, 2005 at 12:35:32PM +1000, Cihan Altinay wrote:
> > > Hi,
> > > 
> > > having a Xen system my Linux tls library path is not
> > > in place (renamed to /lib/tls.disabled).
> > > When I run a program that uses OLE/DCOM (with native
> > > ole libraries) it crashes immediately. Using
> > > LD_LIBRARY_PATH=/lib/tls.disabled wine program
> > > makes it work again.
> > > I am not sure if this is true for all OLE apps.
> > > 
> > > Is this known/expected behaviour or a bug?
> > 
> > Do you have a backtrace of the crash or similar?
> Just wanted to create one with the latest CVS but it seems
> it was fixed some days ago. I investigated a bit and to my
> surprise the problem was in x11drv which was patched
> 2005-12-06.

Obviously this is not true. I found out that the following
When I ran the program first thing this morning I got the following
(with disabled tls libraries):

wine: Unhandled page fault on read access to 0x7e7ffd80 at address 0xb7f223a3
(thread 000f), starting debugger...
err:ntdll:RtlpWaitForCriticalSection section 0x7f6c5560 "x11drv_main.c:
X11DRV_CritSection" wait timed out in thread 000d, blocked by 000f, retrying (60
err:ntdll:RtlpWaitForCriticalSection section 0x7f6c5560 "x11drv_main.c:
X11DRV_CritSection" wait timed out in thread 000b, blocked by 000f, retrying (60
err:dbghelp:pe_load_dbg_file -Unable to peruse .DBG file rpcrt4.dbg ("rpcrt4.dbg")
wine: Unhandled exception 0x0eedfade at address 0x0000:0x404cc6f0 (thread 0009),
starting debugger...
WineDbg starting on pid 0x8

(I couldn't get it to crash yet with WINEDEBUG=relay so that's all output
I can give at the moment...)

If I run it again directly afterwards it works fine - until I wait for
some time (after wineserver has quit) or if I start other programs (like
firefox) it seems. That makes me suspect that it crashes if the process
memory of one of the libraries (or the program itself) is not in the cache
anymore and has to be reloaded.

The program is G-Ware which can be downloaded here:
http://clearone.com/docs/downloads/G-Ware5.0.6.zip [~20MB]
(works only with native ole)

When starting up it uses DCOM to start a "server" (PSRServe.exe).
Two comments on this:
- Even if it crashes it succeeds starting the server
- If the server is started manually (wine psrserve.exe) the program doesn't

As said before, the program works fine when the TLS libraries are in the
library path.


More information about the wine-devel mailing list