CoCreateInstance not working without TLS libraries

Molle Bestefich molle.bestefich at
Fri Dec 16 05:01:18 CST 2005

Alexandre Julliard wrote:
> > Do you think the dependency of wine on TLS will stay in future versions?
> Yes, it can't be fixed, our linuxthreads wrappers can't work in glibc
> 2.3. They work fine with glibc 2.2 though.

TLS can work with Xen, but you have to patch glibc and use

More info (well mostly just assembler code):

More information about the wine-devel mailing list