unable to compile on x86_64 platform

Vincent Béron vberon at mecano.gme.usherb.ca
Fri Feb 4 17:41:43 CST 2005

Le ven 04/02/2005 à 17:24, Noah Schwartz a écrit :
> hey,
> i'm trying to compile wine on my machine (ver. 2005-01-11) but 
> ./configure doesnt get too far...

> configure:1878: checking for C compiler default output file name
> configure:1881: gcc -m32    conftest.c  >&5
> /usr/lib/gcc-lib/x86_64-pc-linux-gnu/3.3.4/../../../../x86_64-pc-linux-gnu/bin/ld: 
> skipping incompatible 
> /usr/lib/gcc-lib/x86_64-pc-linux-gnu/3.3.4/./libgcc.a when searching for 
> -lgcc
> /usr/lib/gcc-lib/x86_64-pc-linux-gnu/3.3.4/../../../../x86_64-pc-linux-gnu/bin/ld: 
> skipping incompatible 
> /usr/lib/gcc-lib/x86_64-pc-linux-gnu/3.3.4/libgcc.a when searching for -lgcc
> /usr/lib/gcc-lib/x86_64-pc-linux-gnu/3.3.4/../../../../x86_64-pc-linux-gnu/bin/ld: 
> cannot find -lgcc

> currently running gentoo.
> kernel version 2.6.9-gentoo-r14.
> glibc version
> gcc version 3.4.3-r1 compiled with multilib which works as far as i know

Are you sure about that last part? (I'm assuming multilib means gcc can
produce both x86 and x86-64 code.)

The lines I kept from you message make it look like gcc only checked in
x86_64 dirs, of course in which it can't find what it's looking for. Or
since it's ld which issues the errors, could it be possible your
binutils are only compiled with x86_64 support and not bot x86 and

Do you have a /usr/lib/gcc-lib/x86-pc-linux-gnu dir?

Last thing (could be a typo on your part): you claim having gcc
3.4.3-r1, but ld is looking in a 3.3.4 dir. Maybe your gcc install is


More information about the wine-devel mailing list