Code cleanup: SHFileOperationW

Mike McCormack mike at
Thu Jan 13 08:28:23 CST 2005

Joris Huizer wrote:

> I took out a part of the function SHFileOperationW and put it in a new 
> function - please give any comments: is this the way to make this 
> function more readable you want it? what is a better way of calling such 
> a function?

Looks like a step in the right direction.  Anything that reduces the 
number of variables, side effects and conditions in that function would 
be appreciated.

Just be careful to make sure it still passes the test cases written for 


More information about the wine-devel mailing list