Code cleanup: SHFileOperationW
rob at codeweavers.com
Thu Jan 13 14:35:26 CST 2005
Mike McCormack wrote:
> Mike Hearn wrote:
>> Yes this looks good but for internal functions IMHO it's best to use
>> GNU style naming, eg:
>> static int file_operation_delete(...)
> SHELL_internal_function() is a better way to go, IMO. It's already
> the Wine convention,
An ugly convention. SHOUTING is not nice to read when using written
communications and it is not nice to read in code.
> you can easily locate the function,
This convention is typically only used for static functions. You should
know if you come across a function named like that then all you have to
do is use your editor's search function to find the function in the file
you're working in.
> and it helps make sure no two functions will be named the same thing.
What is the problem with that?
> There's no reason to make a new convention just because you think the
> old one is "ugly".
If the code makes me want to scratch my eyes out, I'm not likely to want
to hack on it.
More information about the wine-devel