[include/winternl.h #7] SYSTEM_PROCESS_INFORMATION

Paul Vriens Paul.Vriens at xs4all.nl
Mon Jun 6 13:18:13 CDT 2005

On Mon, 2005-06-06 at 19:50, Alexandre Julliard wrote:
> Paul Vriens <Paul.Vriens at xs4all.nl> writes:
> > I removed the __WINESRC__ bit as it will never be used and it makes the
> > (coming) tests look better (no private structure needed). 
> > The Windows struct part in SYSTEM_PROCESS_INFORMATION is wrong anyway
> > (both by size and members).
> Actually in most cases the non __WINESRC__ case is the one you want to
> keep, since it comes from the Microsoft headers. You can replace the
> Reserved things with better names but you should keep at least the
> fields that have explicit names in the MS headers. If you have to
> change the layout more than that something is seriously wrong.


The names for dwUnknown are not important enough to be changed right
now. I will wait with tha,t till I figured out what the dwUnknown's are.



More information about the wine-devel mailing list