[PATCH] FCI work for cabinet.dll [cabinet-fci-patch-02b.diff]

Dimi Paun dimi at lattica.com
Wed Jun 8 12:16:27 CDT 2005


From: "Gerold J. Wucherpfennig" <gjwucherpfennig at gmx.net>

Cool stuff Gerold. A few nits:

> +  if(PFCI_INT(hfci)->fNextCab==TRUE) {

It's better to avoid explicit comparison with TRUE.
What if fNextCab is 10, not 1? It's still true, but
it will fail the above test. Just do:

+  if(PFCI_INT(hfci)->fNextCab) {

Also, I know you're modifying existing code, but if it's not
too much to ask, 2-space indent is hard to read, and the vast
majority of developers do prefer 4-space indent. So if you
don't mind, and we can find a solution, would be great if we
can stick to 4-spaces instead.

-- 
Dimi Paun <dimi at lattica.com>
Lattica, Inc.



More information about the wine-devel mailing list