World of Warcraft

Christoph cr2005 at
Wed Jun 29 17:55:05 CDT 2005

Christoph schrieb:
> Joseph Garvin schrieb:
>> The test realms are up, which lets players test the next patch. Anyone 
>> tried it to see if the problem is fixed?

No, it is not fixed.

> Yes, I'm going to test.
> first gotcha the bizzard char copy page. The page did not work in 
> Firefox. Clicking in a circle, not accepting a new char name. Looked at 
> page source. What a joy. The europe/german Version of the page contains 
> a bag full of typos ... such as not closed tags ! Thanks to the 
> Webdeveloper plugin in Firefox I got finally a test char :-P
> second download tool. 100% cpu and 'nothing' happens until winedbg came 
> up with seg fault. Simply retried 5 times, now it's downloading and 
> uploading with 3040MB/s . Great speedup :=)
> third, ... hey I have to cvs the latest wine ;-)

K. First test run with wine-20050628 with WoW-1.5.1
The "I cannnot click on any NPC" is still there.
Audio is not working (artsdrv) also not with sndrec32.exe ("no sound 
device"). artsd is running and no conn from wine.
Mh, something rotten with wineconfig/registry?! I can see wine is 
loading wineoss.drv instead. Regedit shows me correctly 

Tried alsa, that is working.

New bug in wine-20050628: if WoW looses focus, it minimizes and 
maximizes automatically and steals focus again (I'm using WMaker) more 
worse graphics becomes shifted about +1px+1px every time. Makes game 
unplayable after this. Is the option "UseTakeFocus" = "n" no more working?!

So, now I'm going to patch the game.

K. patched fine. creates a new folder WoWTest with empty wtf/ 
config-Folder so have to adjust settings after a quick run.

Game is up. Still has the "cannot click on NPC"

The cheap wrapper trick is still making it working.

further testing needs now lots more time ;)

> chris

More information about the wine-devel mailing list