Ptrace problem on amd64? (Was: Re: Warcraft III can't find cdrom)

T.J. Zeeman tjzeeman at
Mon Mar 7 14:34:49 CST 2005

On Thu, 2005-03-03 at 17:05 +0100, Thomas Zeeman wrote:
> On Thu, 3 Mar 2005 08:13:13 -0700, Jesse Allen <the3dfxdude at> wrote:
> > Oh do you know any kernel version that does work?
> I don't know of any kernel-version that does work, but I have asked on
> the debian-amd64 list and someone over there claimed succes with
> warcraft 3 on amd64 but he was using cedega. Since 2.4 isn't even

I got a reply on that one and he is using 2.6.10 (debian

Since 2.6.11 was out I tried that one too, but without success.
AFAICT the ptrace patch has not been applied in any form for x86_64 yet.

As an aside I tried several other games I have and SimCity 3000 exhibits
the same behaviour. I could have sworn that I played that game about
half a year ago on the same machine. Unfortunately I no longer have the
installation under which I played it then. It was an earlier version of
debian's pure64 and a sid chroot from around that time is the best
answer my memory can serve.

The last thing I noted was a slight difference in behaviour on mounting
the cdrom. With 2.6.8 I have to become root in the chroot to do an
umount -f /cdrom to get it unmounted in the chroot. With 2.6.10 and .11
I could do it as an ordinary user in the chroot.

Is there anything I could try to figure out through wine's debugoutput?
If so, what channels are recommended to be shown?


PS Are the Debian maintainer and wine on speaking terms again? An
apt-get update showed that 20050211 has entered sid and it wanted to
replace my current install from winehq.

More information about the wine-devel mailing list