Ptrace problem on amd64? (Was: Re: Warcraft III can't find cdrom)

Jesse Allen the3dfxdude at
Mon Mar 7 19:28:36 CST 2005

On Mon, 07 Mar 2005 21:34:49 +0100, T.J. Zeeman <tjzeeman at> wrote:
> On Thu, 2005-03-03 at 17:05 +0100, Thomas Zeeman wrote:
> > On Thu, 3 Mar 2005 08:13:13 -0700, Jesse Allen <the3dfxdude at> wrote:
> > > Oh do you know any kernel version that does work?
> >
> > I don't know of any kernel-version that does work, but I have asked on
> > the debian-amd64 list and someone over there claimed succes with
> > warcraft 3 on amd64 but he was using cedega. Since 2.4 isn't even
> I got a reply on that one and he is using 2.6.10 (debian
> kernel-image-2.6.10-9-amd64-k8).
> Since 2.6.11 was out I tried that one too, but without success.
> AFAICT the ptrace patch has not been applied in any form for x86_64 yet.
> As an aside I tried several other games I have and SimCity 3000 exhibits
> the same behaviour. I could have sworn that I played that game about
> half a year ago on the same machine. Unfortunately I no longer have the
> installation under which I played it then. It was an earlier version of
> debian's pure64 and a sid chroot from around that time is the best
> answer my memory can serve.
> The last thing I noted was a slight difference in behaviour on mounting
> the cdrom. With 2.6.8 I have to become root in the chroot to do an
> umount -f /cdrom to get it unmounted in the chroot. With 2.6.10 and .11
> I could do it as an ordinary user in the chroot.
> Is there anything I could try to figure out through wine's debugoutput?
> If so, what channels are recommended to be shown?
> regards,
> Thomas
> PS Are the Debian maintainer and wine on speaking terms again? An
> apt-get update showed that 20050211 has entered sid and it wanted to
> replace my current install from winehq.

Well, even if cedega works, it doesn't help us.  I'm sure their copy
protection support is completely different.  When copy protection
broke on x86 and wine, the cedega side was completely quiet on it. 
They did have copy protection issues with Red Hat kernels, but they
did not relate at all to the problem I discovered.

Are you using Debian packages for wine?  You should try wine CVS.  If
your memory is correct too, you should build an early 2.6 kernel, like

For tracking down the problem, I used the relay channel.  You could
also use the seh channel too.  But I also inserted my own debug
messages into wine or the linux kernel to show the cpu flags cause I
couldn't even trap the exact failed condition.  And these hacked
versions are already long gone...  so I don't remember.


More information about the wine-devel mailing list