winecfg: Add handling for drive options

Mike McCormack mike at
Wed May 18 01:02:38 CDT 2005

James Hawkins wrote:

>          case WM_COMMAND:
> -            if (HIWORD(wParam) == EN_CHANGE)
> +            switch (HIWORD(wParam))
>              {

I don't know if it's just my opinion, but case statements within case 
statements make the code more difficult to read.  Would you consider 
creating a new function instead?  eg.

     case WM_COMMAND:
         OnCommand( dialog, HIWORD(wParam), LOWORD(wParam) );


More information about the wine-devel mailing list