Small cleanup in list handling

Dimi Paun dimi at lattica.com
Wed May 18 06:57:29 CDT 2005


On Wed, 2005-05-18 at 11:53 +0100, Robert Shearman wrote:
> This patch has already been committed, but for future reference code
> of 
> this form:
> 
> LIST_FOR_EACH( cursor, list)
> {
>     TYPE list_entry = LIST_ENTRY( cursor, TYPE, entry );
>     ...
> 
> Can be replaced by the following for IMHO, slightly more readable
> code:
> 
> LIST_FOR_EACH_ENTRY( list_entry, list, TYPE, entry)
> {
>     ...

Good point. I've used the first version since that was the one
documented in wine/list.h. I'll submit a patch to document the
second version.

-- 
Dimi Paun <dimi at lattica.com>
Lattica, Inc.




More information about the wine-devel mailing list