Blame ExpandEnvironmentStringsA for the failing NT4 test in shlwapi:shreg

Richard Cohen richard at
Mon May 23 11:56:02 CDT 2005

Alexandre Julliard wrote:
> A todo is supposed to mark something that will need to be addressed
> later on. Obviously we can't fix the Windows code, so that's not a
> todo, it's just a behavior of the API that should either be handled by
> the test, or simply not tested at all if the results are not reliable.
Yes, the API is not reliable, but we should make sure that Wine is doing 
  the *right thing*. The above choices make the test suite less useful 
for regression testing.

Surely, it is also good to document any bugs we find in Windows, and, 
though perhaps not for NT4, Microsoft *may* fix them in the future.

Why not rename "todo" to "bug_in" ?

More information about the wine-devel mailing list