BadMatch recurring errors

Jonathan Ernst Jonathan at
Tue Oct 4 20:17:02 CDT 2005

A lot of people are complaining about BadMatch on #winehq and in a lot
of bug reports (old or new). Does someone know what they are about ? It
would be nice to have this class of bugs fixed before 0.9 is out.

shows 19 bugs that have things like:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  73 (X_GetImage)
  Serial number of failed request:  56463
  Current serial number in output stream:  56463

(The numbers change depending on the bug/application)

(03:10:15) jernst: I see a lot of "X Error of failed request: BadMatch (invalid parameter attributes)" (I have this error sometimes) in bug reports. Does someone know why ?
(03:11:22) cmorgan: yeah, people report X Error of failed request daily
on #winehq
(03:12:08) jernst: you know where it comes from ? Does it come from
xorg ?
(03:12:16) cmorgan: i've no idea where it comes from
(03:12:22) cmorgan: i hope we can stop it though
(03:12:33) cmorgan: it seems like a bad thing
(03:12:47) ivanleo: jernst:yeah well age of empires has always had that
(03:13:04) jernst: cmorgan: yep, it appears in many programs. Maybe it's
worth posting to wine-devel ?
(03:13:11) cmorgan: jernst: probably

Thanks for your attention.
Jonathan Ernst <Jonathan at>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url :

More information about the wine-devel mailing list