winelib app compatibility between wine versions

Francois Gouget fgouget at
Thu Oct 27 04:53:48 CDT 2005

On Wed, 26 Oct 2005, Eugene Aksenov wrote:
> our winelib app was originally built/run under wine-*-20050524 and we 
> also ran the binaries under the next versions of wine, for example 
> under wine-20050725. But under wine-20050930 the binary failed to 
> start with 'segmentation fault'.
> i also tried to run from wine-20050524 binary rpm under 
> wine-20050930 -> it failed with the same error. Checked on Fedora 3. 
> wine20050930 was installed from binary rpm.
> Has something been changed in the 'binary' sense or one just should 
> not assume the compatibility between versions for winelib apps ?

There have been changes a bit before 0.9 that broke compatibility with 
old Winelib application. In theory, now that Wine has officially reached 
Beta, this should not happen anymore (this is why these changes had to 
go in before 0.9).

Francois Gouget         fgouget at
     Indifference will certainly be the downfall of mankind, but who cares?

More information about the wine-devel mailing list