Could not determine operating system. Exiting.

Pavel Troller patrol at
Thu Oct 27 10:54:55 CDT 2005

  Congratulations for releasing wine-0.9!
  However, I still have a problem running a program. It's a NT4.0 only program
(at least its vendor is telling it) which I would like to run in wine. It's a
special software made by Siemens to support operation and maintenance of their
telephone exchanges.
  The installation starts, but after clicking the first "Next", just after the
initial information about the program, a small dialog saying "Could not
determine operating system. Exiting" pops up and the installation terminates.
  I've set the windows version in winecfg to NT4.0, as the program expects,
however I've tried another versions too and the program is ignoring it totally.
It's just clean CVS wine installation (no windows).
  Is there a possibility to find, which tricks is the program trying to
determine an OS it's running on ? I've tried WINEDEBUG=+relay, found the place
where the dialog was requested but I didn't find anything suspicious before.

                           With regards, Pavel Troller

More information about the wine-devel mailing list