Wine on Solaris?

Rob D rddone at
Mon Oct 31 21:22:27 CST 2005

Solaris is like the red-headed step child of the Wine world. There are 
several parts that dont build correctly on Solaris 8,9, or 10. Im pretty 
sure Solaris 11 is the same.

Fortunately, Robert Lunnon has a website, 
that has several fixes for building Wine on Solaris 9 and 10. While you may 
not be able to use the patchkit for 10 directly, you may be able to use 
parts of it to deduce what needs to change to get it to compile. Thats what 
I had to do for 8. It worked fine for 9.

The Wine for 10, (on the companion CD) worked fine for me on 10, with the 
exception of the RTLD_FIRST issue, but running the binary on 11 may present 

At 01:52 PM 10/31/2005, you wrote:
>I'm new to this forum, so bear with me...
>I'm trying o build 0.9 on Solaris 11 (nevada) and I'm running into some
>The background is that I'm trying to run ComSoft, a win application to 
>the heatpump in my house. It uses serial comm, just plain 9600 bps, even 
>I tried to use the 20041104 version available on the Solaris 10 companion CD,
>but serial comm seems seriosuly broken on it, and I thought I'd better start
>with something more recent.
>I have added some missing sun-specific pieces from the 20041104 version as it
>was built by someone at Sun, and I have been able to build it, sort of.
>I'm running into problems when I try to start wine, where I get complaints 
>unresolved symbols, all of which are defined in the dll shared libraries.
>I'm puzzled by the naming of the shared libraries and I don't understand how
>they are spposed to be named and used.
>Take the kernel32 dll for instance. It is named /opt/sfw/lib/,
>but during linking it is used as "-lkernel32", and at runtime no symbols are
>I'm trying to get in contact with the engineer at sun who built the 
>version on
>the companion CD, but perhaps someone here can explain how it is supposed to

More information about the wine-devel mailing list